Excalibur Tutorial

Abigail Colson

March 8, 2016

Contents

DOWNIOAING EXCAlIDUL ...ttt e et e e e st e e e e st be e e s snabeeessasbeeeessbeaeessreeessnsens
CrEATING @ MW €S ciiiiiiiiiiiitttee et e ettt et e e e e e sttt e et e e s e s s aa bt teeeeeesea s aareeaeeeessaasassbeeaaeeesesansssaaaeesesssannstraaaeeessnnan
Vo o g Y= a1 <Y o USSR
Vo o g Y=o q o 1= £ U UPR
Ve Fo g T~ T YTy o 1 V=T o £ PSSR
SAVE thE CASE . ettt ettt e h e s bt et e e s bt e e bt e e s bt e e b bt e st e e s bae e sabeesbaeeaareesbeeenans
Calculating expert scores and CoOMDINATIONS .......ccuiiiiiiiiiie et e e e ebre e e e e sbee e e e ereeeeeeraeeeeeanes
Calculating Equal Weight DECISION IMAKEIS ......cccccuiiiiiciieee ettt e e ree e e e ate e e e et ae e e e nreee s earaeas
Calculating Performance Weight DeciSion IMaKEerS .........uuiiecuiiieeiiiee ettt e e e e e
Calculating User Weight DeciSion IMaKErS........cuiiiiiiiiiiiiee ettt et e e e vee e e bee e s s nbee e s e
Creating multiple deCiSioN MAKEIS ....ciiuuiiii e e e e s ee e e s b ae e e s sabeeesenareeas
B IT o] 3V LY LT U1 | £ RSP RRN
oo A g Y= T U1 L (RSP

RODUSTNESS ANGIYSIS ..vveeiieiiiie ettt e e e et e e e st e e e e e abae e e e s abbeeeeaasreeeeanssaeeeansseeesassasesanstaeeeennsenas

FIltering IteMS @Nd EXPEITS....ciiiiiiieiitie ettt ettt et e sb e et e st e st e e s bt e s bbeesabeesabaeesabeesabeeensseesaseeesaseesases



Downloading Excalibur

Excalibur can be downloaded and installed from http://www.lighttwist.net/wp/excalibur. It is only available

for PC.

Creating a new case

Click on File > New Case. The Realisations window of the new case automatically opens. If the window does
not open, click on Items for the window to appear.

File Items Experts Assessments Edit Calculate Window Help
BF TR
B Realisations data: NONAME = =R
Nr. Id Scale  Realization Full Name
1 LOG
Adding items

Type the item’s ID, Scale (either LOG or UNI; see Help > Excalibur Glossary for more information), and Full
Name. If the item is a calibration variable, also type the Realization. Leave Realization blank if the item is
not a calibration variable. TAB moves between an item’s fields. Press ENTER (once or twice, depending on
which cell or row is active) to add a new item.

ID and Scale are required fields. Realization is required for calibration variables. Full Name is optional.

Adding the first 10 items from the Nremoval study looks like this:

File Items Experts Assessments Edit Calculate Window Help
%
B Realisations data: NOMAME = =R ==

Nr. Id Scale  Realization Full Name
1 ouT_W_I UHI 42 outgeing total nitrogen load (kg TN) from the sub-watershed over rain ey
2 ouT_W_h UHI 56 outgeing total nitrogen load (kg TN) from the sub-watershed over rain ey
3 ouT_W_In UNI 133 outgeing total nitrogen load (kg TN) from the sub-watershed over rain ey
4 ouT_W_Iv UHI 22,75 outgeing total nitrogen lead (kg TN) from teh sub-watershed over rain ey
B IN_A_V UHI incoming TN load (kg) to BMP &
<] ouT_A_V UNI outgeing TN load (kg) to BMP A
T IN_B_V UHI incoming TN load (kg) to BMP B
8 OuUT_B_V UHI outgeing TN lead (kg) to BMP B
9 IN_C_V UHI incoming TN load (kg) to BMP C
10 OUT_C_V UMI outgoing T load [ka) to BMP C

The Edit menu allows you to make some changes to all of the items in a case.

Edit > Change all scales to UNI assigns all items in the case a uniform (UNI) scale.

Edit > Change all scales to LOG assigns all items in the case a logarithmic (LOG) scale.

Edit > Change floating point format provides options for the number of decimal places and digits stored for

realizations in the case.


http://www.lighttwist.net/wp/excalibur

File Hems Experts Assessments Edit Calculate Window Help

ol
%
r
B Realisations data: NONAME [=[@][=]
ey . " L
! E& change Floating Point Dat...= BN XN e
1 ing total nitrogen load (kg TN) from the sub-watershed over rail_I
2 Format ing total nitrogen load (kg TN) from the sub-watershed over rai
S o £ (e ancel
3 (2) Fiwed Point () Scientific ing total nitrogen load (kg TN) from the sub-watershed over rai
4 @ Mixed [campact] ing total nitrogen load (kg TN) from teh sub-watershed over rai
5 . i ling TM load (kg) to BMP A
Field width  Dec.places
[ — - ing TN load (kg) to BMP A
g 4 E
T ling TN load (kg) to BMP B
i — — o TN lead (kg) to BMP B
9 IN_C_V LOG incoming TN load (kg) to BMP C i
[l ik

Adding experts

Click Experts. When adding experts to a case for the first time, the Quantiles menu appears. This enables
specification of the number of quantiles (typically 3 or 5) and the relevant percentiles (typically 5, 50, and
95 for 3 quantiles or 5, 25, 50, 75, and 95 for 5 quantiles).

File Ttems Experts Assessments Edit Calculate Window Help

&

B Quentics (el ) [ [=I=IE=]

Futinn Full Name

1 2 3 42 outgeing total nitrogen load (kg TH) from the sub-watershed over rain e\
5 50 a5 56 outgeing total nitrogen load (kg TH) from the sub-watershed over rain e\
3.3 outgeing total nitrogen load (kg TN} from the sub-watershed over rain e\
Mumber of quantiles [3-5) : B2.75 outgoing total nitrogen load (kg TH) from the sub-watershed over rain e
{.35 outgeing total nitrogen load (kg TH) frem the sub-watershed over rain ey

oK ] ’ Cancel ] incoming TH load (kg) to BMP A

outgeing TM load (kg) to BMP A

™8 BV FT T — incoming TN load (kg) to BMP B
-] QuT_B_V UHI outgeing T load (kg) to BMP B
10  IN_C Y UNI incoming TH load (kg) to BMP C.

After confirming the quantiles, the Experts data window appears. Experts are added in the same way as
items. ID is mandatory, and Full Name is optional.

Adding assessments
An expert’s assessments can be viewed in two ways:

1. Double-click the expert’s row in the Expert window.
2. Single click on the expert’s row (column Nr.) in the Expert window to highlight it and click
Assessments.



File Items Experts Assessments Edit Calculate Window Help

EAssessments for the Expert: 10 *‘Thﬁ I_D ?.ng F-U_" _an_mg {tf il@é.‘iﬂi} Q.T t_hg '?.’EP.EI!
who provided these assessments.

Nr. Id Scale Th H¥% 5% Realization Full Name

1 ouT_W_I UNI i 42 outgoing total nitregen load
2 ouT_W_ll UNI 56 outgoing total nitregen load
3 ouT_wW_ll UNI 13.3 outgoing total nitrogen load
4 ouT_W_n UNI 2273 outgoing total nitregen lead
5 OuT_W_W UNI 7.35 outgoing total nitregen load
[ IN_&_V UNI incoming TN load (kg) to Bk
T ouT_A_W UNI outgoing TH load (kg) to BN
8 IN_B_V UNI incoming TM load (kg) to Bk
9 OuT_B_W UNI outgoing TN load (kg) to BNV
10 IN_C_V UNI incoming TN load (kg) to Bk

Type the expert assessment data in this table.

Save the case
Click File > Save As... or File > Save Case to save the case. This creates two files in the specified directory:

e a3 .dttfile containing the expert assessment data
e an .rls file containing the realization data.

Excalibur requires both files to calculate performance scores and combined weights.

The .dtt and .rls files are ascii files. They can be viewed in text editors and other programs. Be careful
editing the files outside of Excalibur, though, as Excalibur depends on the exact spacing it sets in the files.

Opening a case

Click File > Open Case to open a previously saved case file. Note that you only select the .dtt file to open a
case. If the accompanying .rls file is not in the same directory, though, the realizations data will not
properly load.

Calculating expert scores and combinations
The following examples use the Nremoval case files.

Click Calculate to bring up the Run Parameters window, which looks like:



ERun Parameters EI =] @

Set the dezired parameters and click on Calculate/Run

Legacy features

el Chiz I that replicate old
The 4 types of DMs et= @ Global () Equal @ Mew @ Mew 'ﬂ* code. Always use
’ () ltem () User o 1 0ld “New: for.these
parameters.
oM " DM optimization || Bapesian Updates || Discrepancy
“‘# Calibration Power Intrinzic Range
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b

“ _ Decizion Maker Name
onlyj hh=
N emel @elel Calculate Buttons to run

DM calculations
[ RN ] [Hnbustness [ibems] l ’Fiobustness [e:-tperts]l -‘+ and robustness
analysis.

f

| Reset || Cancel |

More information on these parameters is available in the Excalibur Help file and Glossary (found at Help >
Excalibur Help and Help > Excalibur Glossary).

Calculating Equal Weight Decision Makers
To create an Equal Weight Decision Maker named “EW”, use the following Run Parameters:

rE Run Parameters EIE@

Set the desired parameters and click on Calculate/Run

Wieights Chi2 Inf
) Global @) Equal @ Mew @ Mew
) ltem () User o od () 0Id

[~ DM optimization || Bayesian Updates Dizcrepancy

Calibration Power Intrirzic Range
D1<¢= 1000 <=10 001«<= 010 <=1000

Decision Maker Mame
E'f

Calculate

[ RUM ] lHobustnes& [itemnz] l lHnbu&tne&s [e:-:perts]]

’ Reset ” Cancel l




Click Run and produce a table of outputs:

E Expert scores: Nremoval and Relative Inforamtion to DM = || B e
Results of scoring experts and Relative Information to the DM
Bayesian Updates: no  Weights: equal DM Optimisation: no
Significance Level: 0 Calibration Power: 1
MNr. Id Calibr. Mean relative  Mean relative HNumb UnMormalized MNormaliz.weigl Mormaliz.weigt Rel.Infto DM Rel.Inf to DM
total realization real weight without DM with DM total realiz.
11 0.492 2.635 3.747 11 1.544 LIS 0.3577 1.743 2.943
2 2 T.543E-012 5.669 5.987 11 4.516E-011 0.1 8.T63E-012 3.268 2.555
3 3 2.496E-006 2.501 4,367 1 1.09E-005 01 2. 115E-006 1.525 1.391
4 4 0.0007985 1.969 2.731 11 0.002181 0.1 0.0004232 1.808 2.452
5 & 3.211E-014 5.1566 5.639 11 1.8MMEM3 01 3.513E-014 2.553 1.745
6 6 2.789E-005 J.788 4.938 11 0.0001377 0.1 2.6T2E-005 1.722 2.16
77 0.0007985 3.623 4.59 1 0.003665 01 0.0007112 1.733 1.834
3 8 0.7062 2.923 417 11 2.945 0.1 0.5714 1.457 2.616
9 9 0.0011 1.317 2.618 1 0.00288 01 0.0005588 1.442 2,325
10 10 J.211E-014 0.5074 0.3431 11 1.402E-014 LIS 2138E-015 0.9556 1.022
11 EW 0.197 1.19 1.509 1 0.3563 0.06914 1] 0
1 2 3 4 5 6 7 8

The columns in the table display (again, more information is available in Help > Excalibur Help and Help >
Excalibur Glossary):

1. The expert ID (including any decision makers created by the analyst in this session)
The calibration score

3. The information score. The first column is averaged over all items; the second column is averaged
over only the seed questions (i.e., the questions with realizations).

4. The number of seed questions.

5. The combined score (i.e., the product of calibration and information on the seed questions).

6. The normalized expert weight for the most recently calculated decision maker, excluding the
decision maker.

7. The normalized expert weight for the most recently calculated decision maker, including the
decision maker.

8. The discrepancy analysis, comparing the information of the expert to that of the active decision
maker. Note that this is typically used with the Equal Weight Decision Maker. The first column is
averaged over all items; the second column is averaged over only the seed questions (i.e., the
questions with realizations). These columns only appear when Discrepancy is checked.

Calculating Performance Weight Decision Makers
To calculate an optimised performance weight decision maker, check DM optimisation. Select Global or
Item Weights, depending on the weighting scheme desired.



ERun Parameters EI =] @

Set the desired parameters and click on Calculate/Run

Weights Chi2 Inf
@ Glabal Equal @ New @ Mew
Iterm User Oid Oid
| DM optimization B ayezian Updates Discrepancy
Calibration Poveer Intrinzic B ange

01<= 1000 <=1.0 0M<= 010 <=100.0

Decizion Maker Name

G

Calculate

| RUM | |Hnbustness [items] | | Robusthess [experts]|

| Reset || Cancel |

Calculating User Weight Decision Makers

To create a User Weight Decision Maker, make sure DM optimisation is unchecked. Select User Weights in
the Run Parameters window, and the following window pops up:

E Experts data: Mremowval EI@

Mr. Id User Weight Full Name
1 1 0.15

2 2 0.05

3 3 0.1

4 4 0.1

5 5 0.1

6 6 0.1

[ 0.1

& 8 0.1

9 9 0.1

-
=
-
=

Manually enter the weight desired for each expert. Leave the User Weight blank for one expert, and
Excalibur calculates it so that all the user weights sum to 1. After entering the user weights, click Run to see
the expert and decision maker scores.

Creating multiple decision makers
Excalibur allows you to create and compare several decision makers. For example, you can create Equal
Weight, Global Weight, and Item Weight decision makers and compare their scores. To remove the

decision makers you’ve created, click Reset on the Run Parameters window. Note: This removes all decision
makers; you cannot selectively remove decision makers.



Displaying results
Excalibur has several built-in options for displaying results.

Double-clicking a decision maker in the Expert scores window brings up its assessments:

E Solution for: GW (= [=][==]
Resulting solution (combined DM distribution of values assessed by experts)
Soyesn pdatesne Heighte globel, OMOptrisaton: 2= s Parameters used for this DM
Hr. Id Scale T % 5% Realization Full Name -
1 ouT_W_I UNI 36.61 76.43 116.3 42 outgeing total nitrogen load (kg T} from the sub-watershed over rai
2 ouT_wW_Il UMI 39.9 83.3 126.7 56 outgoing total nitrogen load (kg TM} from the sub-watershed over rai
) ouT_W_Il UNI 5.456 11.36 17.26 13.3 outgoing total nitrogen load (kg TN} from the sub-watershed over rai
4 OuT_W_IW UNI 1347 27.49 41.82 2275 outgeoing total nitrogen load (kg TM) frem the sub-watershed over rai
2 ouT_W_W UNI 2.349 4.89 7431 7.35 outgoing total nitrogen load (kg TH) from the sub-watershed over rai
6  IN_AV UMl 0.9459 197 2.993 incoming TH Ioad (kg) to BMP A
7 OUT_AV UNI 0.6441 1.566 3.453 outgoing TN load (kg) from BMP A
8 IN_B_V UNI 0.2235 0.4653 0.7072 incoming TN load (kg) to BMP B
8 OUT_B_V UNI 0.1002 0.2917 0.7043 outgoing TN load (kg) from BMP B
10 IN_C_ W UNI 0.09665 0.2012 0.3058 incoming TN load (kg) to BMP C
11 OuT_C_WV UNI 0.05274 0.1261 0.3397 outoing TM load (kg) from BMP C
12 OUT_W_W1 UNI 63.31 132.2 201 80.5 outgoing total nitrogen load (kg TH) from the sub-watershed over rai
13 IN_A VI UMl 26.2 54.7 3.1 incoming TH Ioad (kg) to BMP A
14 OUT_A_WVI UNI 17.85 43.48 96.1 outgoing TN load (kg) from BMP A

Clicking the Range Graph (expertswise) or Range Graph (itemwise) buttons in the Run Parameters window
creates text range graphs of the experts’ and decision makers’ assessments, ordered either by expert or
item. The itemwise range graphs for the Nremoval study look like:

E Range Graph (Iterns) EI@

Range graph of input data -
Tten no.: 1 Tten nane: OUT_H_T Scale: UWI
Experts

111

i

TTE

ey
(SR =R-C RS T I ATEY )

Itan no.: 2 Iten nane: OUT_H_IT Scale: UWI
Exparts
1 [#]

Tten no.: 3 Tten mane: OUT_H_IIT Scale: UHI

Right-dlick inside the window to export the text

In these text figures, the brackets ([, ]) indicate the range of the assessment, the asterisk (*) indicates the
median, and the hashtag (#) is the realization for the seed items.




These text graphics can be copy/pasted into another program. However, to display properly, they need a
monospace font (e.g., Courier) sized small enough that the assessments are shown on one line of text.

Exporting results
The decision maker assessments can also be exported for use with other programs, such as Excel or R. This
gives more flexibility in displaying results or conducting additional analysis.

To export the quantiles (i.e., the percentiles elicited) or full distributions, go to File > Export as space
delimited and choose Quantiles or Distributions (the latter extrapolates the full distribution based on the
elicited percentiles and the uniform or log uniform distribution). A window appears that lets you select
which items and experts/decision makers to export. Click Export to save the file. This creates an ascii file
with the extension .dis that can be read in a text editor or imported into Excel, R, or the program of your
choice.

-

E Experting Case Data =ANCE X
F3 to toggle all an/off
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You can also export most windows (e.g., DM Solution, Export Scores, etc) to text files by selecting the
window and then clicking File > Export as text and selecting the window type. Note that only the active
window will be available to export as text.

Robustness analysis
Excalibur features two built-in options for robustness analysis: robustness on items and on experts.

To run the robustness analysis, go to the Run Parameters window (if it isn’t visible, click Calculate). Click
Robustness (items) or Robustness (experts). Robustness on items removes seed items one at a time and
recalculates the decision maker (using the settings in the Run Parameters window). Robustness on experts
removes experts one at a time and recalculates the decision maker. More information is available in Help >
Excalibur Help.



Filtering items and experts

In addition to the simple built-in robustness analysis, Excalibur allows you to filter out experts and/or items
and recalculate decision makers, getting more information than the robustness analysis provides. For
example, you can remove an expert, create the Global Weight Decision Maker, and then export the
guantile assessments of this decision maker to explore the results if one expert had been excluded.

WARNING! Always store a safe copy of your data before filtering items and/or experts. NEVER click Reset
on the Run Parameters window while items or experts are filtered. This will delete the filtered
items/experts. Instead, undo the filtering so the experts/items are active again, and then Reset.

To filter items, click Items to bring up the items window. Click on the row to highlight the item you’d like to
filter (i.e., remove from the subsequent calculations) and then press F4 or click Edit > Filter Experts/Items.
To undo the filtering, highlight the row and press F4 or click Edit > Filter Experts/Items again. To undo all
filtering, press F5 or click Edit > Disable Filtering. This makes everything active. To re-enable filtering, press
F5 again or click Edit > Enable Filtering.

To filter experts, click Experts to bring up the experts window and follow the same instructions as for
filtering items.

Filtered experts/items appear in grey rather than black, but that can be tough to see on some displays.



